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RESUMO 
 
 

A utilização de estruturas executadas com mastros metálicos, cabos de alta resistência 

e tecido sintético, as estruturas de membrana tracionada por cabos, experimentou um 

crescimento bastante significativo na última década do século XX. Edificações para as mais 

variadas funções foram construídas com essa tecnologia.  

O objetivo desta dissertação de mestrado é a integração dos programas Membrane, 

Lights e GiD para análise preliminar da geometria e das tensões da cobertura do Centro 

Comunitário Athos Bulcão/UnB visto que o programa Lights embora resolva problemas 

enfrentados por outros sistemas (Nastran, Ansys) na análise de estruturas com deslocamentos 

finitos, não dispõe de métodos de pré e pós processamento. O programa GiD é destinado a 

esse fim, perante acoplamento com sistemas desenvolvidos pelo usuário. 

 Os programas Membrane, Lights e GiD foram integrados tornando possível o 

intercâmbio de arquivos e resultados entre esses programas, além da visualização gráfica no 

GiD das tensões e deslocamentos calculados pelo Membrane e pelo LightsGiD. Foi elaborado 

um manual com um exemplo desenvolvido passo a passo que engloba essas possibilidades de 

integração.  

 Os resultados obtidos impondo carregamento estático de vento e pré-tracionamento 

mostram o quanto é importante conhecer os parâmetros que definem as características 

mecânicas da membrana a ser utilizada e como é complexa a análise desse tipo de estrutura, 

sendo necessária a realização de testes em túnel de vento para que seu efeito possa ser 

avaliado adequadamente. 

 A análise dos resultados da simulação do Centro Comunitário Athos Bulcão/UnB 

ficou prejudicada devido à falta de informações a respeito dos materiais empregados na 

construção e de detalhamento de projeto. 
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ABSTRACT 
 
 

The use of structures built with metallic masts, high resistance cables and synthetic 

fabric, tensioned fabric structures, had a quite significant growth in the last decade of the 20th 

century. Constructions for different purposes were built with this technology.    

   The goal of this master thesis is the integration of Membrane, Lights and GiD 

programs for preliminary geometry and tension analysis of the roof of the Centro Comunitário 

Athos Bulcão/UnB because even though the program Lights solves problems faced by other 

systems (Nastran, Ansys) in the analysis of structures with finite displacements, it doesn't 

have pre and post processing methods. GiD was a program made for this purpose, using 

systems developed by the user. 

   The programs Membrane, Lights and GiD were integrated, making it possible to 

exchange files and results among these programs, besides the graphic visualization in GiD of 

the tensions and displacements calculated by Membrane and LightsGiD. A manual was 

created with an example developed step by step which includes all these integration 

possibilities.  

   The obtained results with static wind load and pre tensioning show how important it is 

to know the parameters that define the mechanical characteristics of the membrane to be used 

and how complex is the analysis of this structure type. To evaluate properly the effects of the 

wind, it is necessary to make wind tunnel tests. 

   The Centro Comunitário Athos Bulcão/UnB simulation results analysis was not very 

accurate due to lack of information about the materials used in the construction and a detailed 

project. 



 viii

LISTA DE FIGURAS 
 
 
Figura 1.1:  Centro Comunitário Athos Bulcão / UnB, Brasília ........................................... 2 

Figura 2.1: Tipos de tenda ..................................................................................................... 3 

Figura 2.2: Complexo Olímpico em Munique, Alemanha. ................................................... 4 

Figura 2.3: Vista aérea do Complexo Olímpico em Munique, Alemanha ............................ 5 

Figura 2.4: Classificação das tensoestruturas em membrana. ............................................... 6 

Figura 2.5: Esquema de estruturas pneumáticas.................................................................... 6 

Figura 2.6: Estruturas pneumáticas ....................................................................................... 7 

Figura 2.7: Principais tipos de estruturas de membrana tracionada por cabos...................... 8 

Figura 2.8: Arranjos típicos dos fios nas membranas estruturais .......................................... 9 

Figura 2.9: Exemplo esquemático de membrana estrutural com matriz de revestimento... 10 

Figura 2.10: Alongamento biaxial típico de membranas..................................................... 11 

Figura 2.11: Estruturas de membrana com apoios pontuais................................................ 12 

Figura 2.12: Estruturas de membrana com apoios em arcos ............................................... 12 

Figura 2.13: Exemplo de estrutura de membrana no Brasil: Restaurante Barra Vento,  

Salvador ............................................................................................................................... 15 

Figura 2.14: Auditório Araújo Viana, Porto Alegre............................................................ 16 

Figura 2.15: Foto recente do Auditório Araújo Viana, Porto Alegre.. ................................ 16 

Figura 2.16: Etapas de projeto de uma estrutura de membrana tracionada com cabos....... 17 

Figura 3.1: Esquema dos programas elaborados (azul) e modificado (verde) .................... 26 

Figura 4.1: Malha de elementos finitos triangulares de três nós obtida no GiD ................. 28 

Figura 4.2: Geometria indeformada em três dimensões obtida com o Membrane visualizada 

no AutoCad.......................................................................................................................... 28 

Figura 4.3: Tensão principal 1 no GiD (kPa) ...................................................................... 29 

Figura 4.4: Tensão principal 2  no GiD (kPa) ..................................................................... 29 

Figura 4.5: Deslocamentos dos nós na direção z no GiD (m) ............................................. 29 

Figura 4.6: Resultado do Lights com cabo 1 no AutoCad .................................................. 30 

Figura 4.7: Um quarto da superfície de membrana para gerar a malha a ser espelhada no 

GiD ...................................................................................................................................... 31 

Figura 4.8: Malha simétrica de elementos finitos triangulares de três nós obtida no GiD.. 31 

Figura 4.9: Geometria indeformada obtida no Membrane com visualização no AutoCad . 32 

Figura 4.10: Resultado do Lights com cabo 1 no AutoCad ................................................ 32 



 ix

Figura 4.11: Resultado do Lights com cabo 15 no AutoCad .............................................. 32 

Figura 4.12: Resultado do Lights com cabo 15 renderizado no AutoCad........................... 33 

Figura 4.13: Resultado do Membrane (Borges) no AutoCad.............................................. 33 

Figura 4.14 - Malha simétrica de elementos finitos triangulares de três nós com flecha 

reduzida obtida no GiD ....................................................................................................... 34 

Figura 4.15: Resultado do Membrane (Borges) no AutoCad.............................................. 34 

Figura 4.16: Resultado do Membrane (Borges) com renderização no AutoCad................. 34 

Figura 4.17: Malha simétrica de elementos finitos triangulares de três nós obtida no GiD 36 

Figura 4.18: Geometria indeformada obtida no Membrane com visualização no AutoCad36 

Figura 4.19: Deslocamentos dos nós no GiD (m), resultado do Membrane ....................... 36 

Figura 4.20: Visualização no AutoCad da geometria inicial sobre a qual foram aplicados os 

carregamentos...................................................................................................................... 37 

Figura 4.21: Visualização no AutoCad da configuração deformada da membrana com 

cabo 6, resultado do LightsGiD, sucção .............................................................................. 37 

Figura 4.22: Força atuando nos cabos de borda 6 com sucção e sobrepressão (kN)........... 38 

Figura 4.23: Deslocamentos dos nós com cabo 6 sem pré-tracionamento, sucção (m) ...... 38 

Figura 4.24: Tensão principal 1 nos elementos da membrana com a estrutura submetida a 

sucção e com os cabos sem pré-tracionamento (kPa) ......................................................... 38 

Figura 4.25: Tensão principal 2 nos elementos da membrana com a estrutura submetida a 

sucção e com os cabos sem pré-tracionamento (kPa) ......................................................... 39 

Figura 4.26: Visualização no AutoCad da configuração deformada da membrana com 

cabo 6, resultado do Lights, sobrepressão ........................................................................... 39 

Figura 4.27: Deslocamentos dos nós com cabo 6 sem pré-tracionamento, sobrepressão (m)39 

Figura 4.28: Tensão principal 1 nos elementos da membrana com a estrutura submetida a 

sobrepressão e com os cabos sem pré-tracionamento (kPa)................................................ 40 

Figura 4.29: Tensão principal 2 nos elementos da membrana com a estrutura submetida a 

sobrepressão e com os cabos sem pré-tracionamento (kPa)................................................ 40 

Figura 4.30: Superfície com linhas guias para geração de malha de elementos finitos ...... 41 

Figura 4.31: Visualização no AutoCad da configuração deformada da membrana com 

cabo 6, resultado do Lights, sucção..................................................................................... 42 

Figura 4.32: Força atuando nos cabos de borda 6 sob sucção (kN) .................................... 42 

Figura 4.33: Tensão principal 1 nos elementos da membrana com a estrutura submetida a 

sucção e com os cabos com pré-tracionamento (kPa) ......................................................... 42 



 x

Figura 4.34: Tensão principal 2 nos elementos da membrana com a estrutura submetida a 

sucção e com os cabos com pré-tracionamento (kPa) ......................................................... 43 

Figura 4.35: Visualização no AutoCad da configuração deformada da membrana com 

cabo 6, resultado do Lights, sobrepressão ........................................................................... 43 

Figura 4.36: Força atuando nos cabos de borda 6 sob sobrepressão (kN)........................... 43 

Figura 4.37: Tensão principal 1 nos elementos da membrana com a estrutura submetida a 

sobrepressão e com os cabos com pré-tracionamento (kPa) ............................................... 44 

Figura 4.38: Tensão principal 2 nos elementos da membrana com a estrutura submetida a 

sobrepressão e com os cabos com pré-tracionamento (kPa) ............................................... 44 

Figura 4.39: Detalhes de fixação da membrana .................................................................. 45 

Figura 4.40: Vista superior e inferior do modelo com elementos de membrana (verde), de 

cabo (azul) e mastro (magenta) ........................................................................................... 45 

Figura 4.41: Vista lateral e detalhe de fixação da membrana no mastro lateral.................. 46 

Figura 4.42: Vista parcial do modelo com elementos de membrana, cabo e mastro além de 

visualização de detalhes de fixação da membrana nos mastros principais.......................... 46 

Figure A.1: Scheme of the developed (blue) and modified (green) programs .................... 55 

Figure A.2: A view of what was drawn in AutoCAD with the corner coordinates............. 57 

Figure A.3: NURBS Surface created................................................................................... 58 

Figure A.4: Node, line and surface numbers ....................................................................... 58 

Figure A.5: Mesh view with node (black), cable and membrane elements (green) 

numbers ............................................................................................................................... 59 

Figure A.6: Instructions to mirror the geometry, first step.................................................. 59 

Figure A.7: Instructions to mirror the geometry, second step ............................................. 60 

Figure A.8: Complete geometry .......................................................................................... 60 

Figure A.9: Instructions to mirror the finite element mesh, first step ................................. 61 

Figure A.10: Instructions to mirror the finite element mesh, second step........................... 62 

Figure A.11: Complete mesh with corner node numbers.................................................... 62 

Figure A.12: Generated mesh with normal vectors............................................................. 63 

Figure A.13: Deformed mesh top view in AutoCAD.......................................................... 66 

Figure A.14: Deformed and undeformed meshes in AutoCAD .......................................... 66 

Figure A.15: Deformed mesh top view in GiD Postprocess ............................................... 67 

Figure A.16: Rotated deformed mesh top view in GiD Postprocess................................... 67 

Figure A.17: One of the results possibilities: Y Displacement ........................................... 67 

Figure A.18: View of membrane, cable and frame elements in AutoCAD......................... 74 



 xi

Figure A.19: Membrane (green), cable (blue) and frame (magenta) elements view in GiD 

Postprocess .......................................................................................................................... 74 

Figure A.20: Some results in GiD Postprocess ................................................................... 75 

Figure A.21: Deformed and undeformed meshes in AutoCAD .......................................... 77 

Figure A.22: Membrane (green) and cable (blue) elements shown in GiD Postprocess..... 77 

Figure A.23: Some results in GiD Postprocess ................................................................... 78 

 

 
 
 
 



 xii

SUMÁRIO 
 

1. INTRODUÇÃO ................................................................................................................1 

2. REVISÃO BIBLIOGRÁFICA ........................................................................................3 

2.1. BREVE HISTÓRICO SOBRE AS ESTRUTURAS DE MEMBRANA..............3 

2.2. PRINCIPAL CLASSIFICAÇÃO DAS TENSOESTRUTURAS EM 

MEMBRANA...................................................................................................................5 

2.2.1. Estruturas de membrana tracionadas por cabos.........................................8 

2.3. MATERIAIS UTILIZADOS EM TENSOESTRUTURAS ..................................9 

2.4. CARACTERÍSTICAS DAS TENSOESTRUTURAS .........................................13 

2.5. UTILIZAÇÃO DAS ESTRUTURAS DE MEMBRANA....................................14 

2.6. ETAPAS DO PROJETO DE TENSOESTRUTURAS EM MEMBRANA.......16 

2.6.1. Busca da forma .............................................................................................17 

2.6.2. Projeto de cortes ...........................................................................................18 

2.6.3. Análise estrutural..........................................................................................19 

2.7. RECOMENDAÇÕES GERAIS DE PROJETO ..................................................20 

2.8. PRINCIPAIS MÉTODOS NUMÉRICOS PARA ESTRUTURA DE 

MEMBRANA.................................................................................................................21 

2.8.1. Lights .............................................................................................................22 

3. METODOLOGIA...........................................................................................................23 

3.1. ESTUDOS DIRIGIDOS.........................................................................................23 

3.2. ANÁLISE DO PROJETO DO CENTRO COMUNITÁRIO .............................24 

3.3. PROGRAMAS ........................................................................................................24 

3.4. ESTÁGIO ................................................................................................................24 

3.5. DESENVOLVIMENTO DE PROGRAMAS E PROCEDIMENTOS EM 

ADA 95............................................................................................................................25 

3.6. ANÁLISE DE TENSÕES E DESLOCAMENTOS DA 

TENSOESTRUTURA DE COBERTURA DO CENTRO COMUNITÁRIO DA 

UNIVERSIDADE DE BRASÍLIA................................................................................27 

3.7. ELABORAÇÃO DO MANUAL PARA UTILIZAÇÃO DOS 

PROGRAMAS DESENVOLVIDOS............................................................................27 



 xiii

4. RESULTADOS E DISCUSSÃO ...................................................................................28 

5. CONCLUSÕES...............................................................................................................47 

6. SUGESTÕES PARA TRABALHOS FUTUROS ........................................................48 

REFERÊNCIAS BIBLIOGRÁFICAS .............................................................................49 

APÊNDICE A - MANUAL ................................................................................................53 

A.1. GENERAL INFORMATION...............................................................................53 

A.2. GiD PREPROCESS...............................................................................................56 

A.2.1. First option: Import the membrane contour drawing from AutoCAD..56 

A.2.2. Second option: Draw the membrane contour inside GiD ........................57 

A.2.3. After importing the membrane contour from AutoCAD or drawing it 

inside GiD ................................................................................................................58 

A.3. GiDMEMBRANE ..................................................................................................64 

A.4. MEMBRANE .........................................................................................................66 

A.5. GiD POSTPROCESS.............................................................................................67 

A.6. MEMBRANELIGHTS..........................................................................................68 

A.7. GiDLIGHTS ...........................................................................................................70 

A.8. LIGHTSGiD ...........................................................................................................72 

A.8.1. From MembraneLights ...............................................................................72 

A.8.2. From GiDLights...........................................................................................75 

APÊNDICE B - CD ............................................................................................................79 

 
 

 

 
 



 1
 
1. INTRODUÇÃO 

 

 

A utilização de estruturas executadas com mastros metálicos, cabos de alta resistência 

e tecido sintético (fabric structures) experimentou um crescimento bastante significativo na 

última década do século XX. Edificações para as mais variadas funções foram construídas 

com essa tecnologia.  

Embora com algumas dificuldades técnicas ainda não superadas, esse tipo de partido 

estrutural apresenta vantagens importantes, dentre as quais se destacam: vencimento de 

grandes vãos; baixo peso próprio; facilidade de fabricação e montagem; facilidade de 

transporte para outro local; uso do tecido sintético como elemento estrutural e de vedação.  

 Da pesquisa bibliográfica realizada pela autora, pelo orientador e pesquisadores da 

Unicamp é fácil depreender-se que não se tem ainda estabelecida uma metodologia 

preponderante para o cálculo (análise e dimensionamento) dessas estruturas.  

 O objetivo desta dissertação de mestrado é a integração dos sistemas Membrane, 

Lights e GiD para análise preliminar da geometria e das tensões da cobertura do Centro 

Comunitário Athos Bulcão da Universidade de Brasília (UnB) (Fig. 1.1) visto que o programa 

Lights embora resolva problemas enfrentados por outros sistemas (Nastran, Ansys) na análise 

de estruturas com deslocamentos finitos, não dispõe de métodos de pré e pós-processamento. 

O programa GiD é destinado a esse fim, perante acoplamento com sistemas desenvolvidos 

pelo usuário. 

 Os programas Membrane, Lights e GiD foram integrados através do desenvolvimento 

dos programas GiDLights, GiDMembrane e MembraneLights, tornando possível o 

intercâmbio de arquivos e resultados entre esses programas, além da visualização gráfica no 

GiD das tensões e deslocamentos calculados pelo Membrane e pelo LightsGiD. O LightsGiD 
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é uma versão do Lights com procedimentos desenvolvidos neste trabalho que geram os 

arquivos que permitem a visualização dos resultados no ambiente GiD de pós-processamento. 

 Para facilitar o uso por outras pessoas foi elaborado um manual de utilização 

(Apêndice A) com um exemplo disponibilizado no CD (Apêndice B), junto com os 

executáveis e arquivos com o código fonte dos programas. 

 A análise dos resultados da simulação do Centro Comunitário Athos Bulcão/UnB 

ficou prejudicada devido à falta de informações a respeito dos materiais empregados e de 

detalhamento de projeto. 

 

   

  
Figura 1.1: Centro Comunitário Athos Bulcão/UnB, Brasília.1 

                                                 
1 Fotos da autora, em 20/04/2005. 
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2. REVISÃO BIBLIOGRÁFICA 

 

 

2.1. BREVE HISTÓRICO SOBRE AS ESTRUTURAS DE MEMBRANA 

 

 

A origem das estruturas de membrana tensionadas se encontra nas tendas e nos toldos 

tradicionais. Tendas de dimensões consideráveis e de certa sofisticação remontam a pelo 

menos dois mil anos. Reconhece-se por meio de representações e descrições arquitetônicas, 

muitos teatros e anfiteatros romanos que eram feitos de velaria produzida a partir de linhas de 

tecido. 

 As tendas feitas de peles de animais ou materiais tramados foram usadas ao longo da 

história e têm sido utilizadas pelo mundo inteiro, particularmente em sociedades nômades que 

necessitam de coberturas portáteis. Exemplos de tendas usadas no passado incluem as tribos 

nativas americanas (Fig. 2.1: (a)), os abrigos mongóis (Fig. 2.1: (b)) e a tenda negra utilizada 

pelos povos nômades no Saara, Arábia e Irã (Fig. 2.1 (c)). Essa última é denominada dessa 

maneira por causa do emprego de tecido de pêlo negro de bode. Como apresenta cor escura, a 

tenda negra proporciona sombra e a trama aberta permite o escape do ar quente. 

 
Figura 2.1: Tipos de tenda1: (a) tenda cônica; (b) tenda “kibitka”; e (c) tenda negra  

 

                                                 
1 Modificada de Harris & Li (1996) 
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Houve pouco desenvolvimento das tendas entre o tempo dos Romanos e o século XIX, 

em parte por causa da carência de demanda, e principalmente por causa da carência de 

avanços na manufatura de cabos, tecidos e conexões resistentes. Porém, depois da Revolução 

Industrial houve uma demanda por tendas grandes (utilizadas para o entretenimento de 

populações, como os circos) e por materiais de grande resistência, com produção em massa e 

relativamente barata (Borges, 2004). 

A estrutura pneumática que inaugurou a era moderna das tensoestruturas foi projetada 

e executada por Walter Bird em 1946 na construção de uma proteção para uma antena de 

radar nos Estados Unidos. Com o sucesso dessas estruturas, ele abriu uma empresa 

especializada em tensoestruturas em 1956 que atua até hoje, a Birdair. 

Em 1967, Frei Otto, um especialista alemão em estruturas tracionadas construiu o 

Pavilhão da Alemanha na Exposição de Montreal. Como nesta época não existia membrana 

com resistência suficiente para ser suspensa pelos mastros e tracionada pelos cabos de borda, 

foi utilizada uma rede de cabos com uma membrana sobre ela, apenas com a função de vedar. 

Outro projeto que segue a mesma linha, construído em 1971, também de autoria de Frei Otto 

é o Complexo Olímpico de Munique (Figs. 2.2 e 2.3) (Oliveira, 2001). 

         
Figura 2.2: Complexo Olímpico em Munique, Alemanha.1  

 

 

                                                 
1 Fotos da autora, em 16/01/2005. 
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Figura 2.3: Vista aérea do Complexo Olímpico em Munique, Alemanha. 1  

 

 

2.2. PRINCIPAL CLASSIFICAÇÃO DAS TENSOESTRUTURAS EM MEMBRANA 

 

 

Segundo Lewis (1998), a tensoestrutura em membrana é uma das categorias de um 

amplo grupo de estruturas não-convencionais chamadas tensoestruturas leves (Fig. 2.4), que 

além da estrutura de membrana ainda inclui as redes de cabos tracionados e os sistemas 

cabos-treliça. A membrana estrutural é o principal elemento que distingue as tensoestruturas 

em membrana das demais. Para um desempenho satisfatório, como colocam Haber & Abel 

(1982), essas estruturas precisam ser projetadas de maneira que mesmo quando não se 

considere qualquer carregamento atuante, toda a membrana esteja submetida a um estado de 

tensão de tração. Esse estado de tensão, chamado “pré-tracionamento”, é um dos pontos 

                                                 
1 Foto da autora, em 16/01/2005. 
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fundamentais do projeto das tensoestruturas em membrana. Ele exerce influência direta sobre 

a forma da estrutura, sua durabilidade e a amplitude de seus deslocamentos quando carregada.  

Os principais elementos de aplicação do pré-tracionamento à membrana desse tipo de 

tensoestruturas são: cabos tensores e pressão de ar. Quando o principal elemento de 

tracionamento da membrana é o cabo tensor, a estrutura é chamada estrutura de membrana 

tracionada por cabos. Da mesma forma, quando o tracionamento da membrana se dá por 

pressão de ar, a estrutura é classificada como estrutura pneumática (Figs. 2.5 e 2.6) (Lewis, 

1998; Oliveira, 2001).  

 

  

Tensoestruturas  
leves  

 
Redes de cabos  Tensoestrutura Sistema  

tracionados em membrana Cabo-Treliça  

 

Tracionadas   
 Pneumáticas por cabos  
 

Figura 2.4: Classificação das tensoestruturas em membrana. 
 
 
 

 
Figura 2.5: Esquema de estruturas pneumáticas. 1 

 

                                                 
1 Pauletti (2003). 
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    (a)            (b) 

     

(c) (d) 

 

(e) 
 

Figura 2.6: Estruturas pneumáticas: (a) Arena Romana de Nîmes, França1; (b) Pavilhão 
alemão da Expo’92 em Sevilha, Espanha2; (c) Tokyo Dome, Japão1; (d) Cobertura de Campo 

de Golfe, EUA1; (e) Pavilhão de Exposições da Mercedes-Benz, Brasil3. 
 

 

                                                 
1 Oliveira (2001) 
2 Pauletti (2003) 
3 Foto obtida do site: www.pistelli.com. Acesso em 20/10/2006. 

 

http://www.geigerengineers.com/
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2.2.1. Estruturas de membrana tracionadas por cabos 

 

 

Entre as estruturas de membrana tracionada por cabos, o principal aspecto que 

assegura a estabilidade da membrana é a superfície de dupla curvatura oposta (“anticlastic 

surface”). Segundo Vandenberg (1996), existem duas famílias consideradas “formas puras” 

com superfície de dupla curvatura oposta e curvatura média nula, os parabolóides 

hiperbólicos, (Fig. 2.7: (a)), e os catenóides, (Fig. 2.7: (b)). Quando essas superfícies 

correspondem à superfície de mínima área para um dado contorno, são chamadas superfícies 

de mínima área. Essas são formas ideais que proporcionam uma distribuição uniforme de 

tensão, sem cisalhamento, por toda a membrana. Os modelos produzidos com filme de sabão 

têm a interessante propriedade de sempre assumirem a forma de mínima área. As formas dos 

parabolóides hiperbólicos e catenóides podem ser modificadas com a introdução de picos 

agudos, picos abaulados (Fig. 2.7: (c)) e cristas (Fig. 2.7: (d)) (Borges, 2004). 

 

  

Figura 2.7: Principais tipos de estruturas de membrana tracionada por cabos1: (a) parabolóide 
hiperbólico; (b) catenóide; (c) e (d) superfícies modificadas. 

 

                                                 
1 Modificado de Vandenberg (1996). 
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As estruturas pneumáticas são recomendadas quando superfícies sinclásticas, com 

curvaturas de mesmo sinal, são desejadas. Nesse caso, a pressão do ar funciona como um 

carregamento transversal que permite a geração de formas convexas como balões ou esferas 

(Figuerola, 2004). 

 

 

2.3. MATERIAIS UTILIZADOS EM TENSOESTRUTURAS 

 

 

Os componentes básicos de tensoestruturas são as membranas (mantas sintéticas), as 

cordoalhas de aço, as estruturas de suporte e os elementos de ancoragem e fundação. O 

principal material utilizado para a confecção das tensoestruturas são as mantas.  

 O tecido e a matriz de revestimento são os componentes básicos das membranas 

estruturais. Muitas vezes também é acrescentado um revestimento de superfície (Figs. 2.8 e 

2.9). 

 

 

Figura 2.8: Arranjos típicos dos fios nas membranas estruturais1: 
 (a) fios sobrepostos; e (b) tecido padrão. 

 

                                                 
1 Borges (2004). 
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Figura 2.9: Exemplo esquemático de membrana estrutural com matriz de revestimento.1 

Existem muitos tipos de tecidos que podem ser utilizados na construção das 

tensoestruturas. A escolha varia de acordo com a demanda; como malha estrutural podem-se 

citar a fibra de vidro, o poliéster, o kevlar (fibra de carbono), ou o nylon e como revestimento 

existem o cloreto polivinílico (PVC), o politetrafluoretileno (PTFE), o teflon (PVDF), ou o 

silicone. 

 A escolha do tipo de membrana deve levar em consideração características tais como 

resistência mecânica, permeabilidade, resistência ao fogo, peso próprio, durabilidade, 

isolamento térmico e translucidez. Como o custo é fortemente influenciado pela durabilidade, 

geralmente projetos temporários são confeccionados com membrana de tecido poliéster 

revestido com PVC e projetos permanentes mais requintados com membrana constituída por 

fibras de vidro revestidas com teflon ou silicone (Oliveira, 2001). 

 As membranas revestidas com PVC/Poliéster são auto-retardantes em caso de 

incêndio. Já as membranas de PTFE e Teflon não pegam fogo. Todas essas membranas são 

aceitas pelas normas internacionais para utilização em estruturas permanentes (Figuerola, 

2004). 

 Algumas características específicas de membranas estruturais que não podem ser 

esquecidas durante o processo de escolha do material são: deterioração e diminuição 

considerável da resistência das mesmas com o tempo de uso, a exposição à radiação 

ultravioleta e a absorção de umidade. Esses dois últimos problemas citados podem ser 

minimizados dependendo do tipo revestimento de superfície aplicado. 
                                                 
1 Borges, 2004. 
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 O conhecimento da relação tensão-deformação é muito importante em todas as etapas 

de projeto de tensoestruturas, mas sua determinação pode ser difícil em virtude do 

comportamento não-linear, ortotrópico e muitas vezes inelástico que as membranas estruturais 

apresentam. As relações tensão-deformação na direção do urdume e da trama são 

significativamente diferentes (Fig. 2.10). Além disso, em geral, existe grande diferença entre 

o comportamento da membrana no primeiro carregamento e nos carregamentos subseqüentes 

(Borges, 2004). 

 Tensão (PLI) 

                           

Alongamento (%)

Urdume Trama 

Figura 2.10: Alongamento biaxial típico de membranas.1 
 

A estrutura de sustentação das membranas tensionadas pode ser madeira ou ligas 

metálicas como aço e alumínio, com apoios pontuais (Fig. 2.11) ou em arcos (Fig. 2.12). 

No caso de estruturas metálicas, o alumínio apresenta alta resistência à corrosão, 

menor peso que o aço, porém resistência mecânica inferior. O aço é a alternativa mais 

interessante quando se necessita de alta resistência mecânica.      

Os arranjos estruturais, via de regra, consistem em reticulados espaciais em que as 

barras ficam sujeitas exclusivamente a esforços axiais de compressão. Essa configuração 

                                                 
1 Modificado de www.birdair.com. Acesso em 15/04/2005. 

 

http://www.birdair.com/
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garante alta eficiência estrutural, uma vez que as barras são solicitadas da forma que permite o 

melhor aproveitamento da capacidade resistente do material.  

 As barras que compõem a estrutura em geral possuem seção transversal tubular. Essa 

forma garante boa rigidez com pouca quantidade de material, resultando em estruturas leves e 

muito resistentes (Borges, 2004).  

 

(a)                                              (b)                                              (c) 

   

(d)     (e) 

Figura 2.11: Estruturas de membrana com apoios pontuais: (a) Terminal Haj, Arábia Saudita1; 
(b) Estádio do Rei Fahd, Arábia Saudita1; (c) Aeroporto de Denver, EUA2; (d) acesso ao 

Millenium Dome, Inglaterra3; e (e) Millenium Dome, Inglaterra4. 
 

    
Figura 2.12: Estruturas de membrana com apoios em arcos: (a) Lindsay Park, Canadá1;  

                                                

(a)                                              (b)                                          (c) 

(b) Laboratório de pesquisa da M&G, Itália5; e (c) Myao Li Arena, Taiwan1. 

 
1 Foto obtida do site: www.geigerengineers.com. Acesso em 16/01/2004. 
2 Foto obtida do site:  www.birdair.com/birdair/about/tension/index.html. Acesso em 16/01/2004. 

  
agina2.htm. Acesso em 

3 Foto da autora, em 06/03/2005. 
4 Foto obtida do site: http://wwp.millennium-dome.com/. Acesso em 10/05/2005. 
5 Foto obtida do site e modificada:
http://www.upc.es/ca1/cat/recerca/tensilestruc/webdetalles/esquina/Cablecontinuo/p
24/04/2004. 
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• Vencimento de grandes vãos: Pelos materiais e sistema estrutural utilizado as 

tensoestruturas são capazes de vencer vãos maiores que qualquer outro tipo de sistema 

construtivo convencional. 

2.4. CARACTERÍSTICAS DAS TENSOESTRUTURAS 

 

 

• Facilidade de desmontar: Apesar de existirem várias estruturas permanentes deste tipo, 

as desmontáveis já possuem uma fatia do mercado. Os investidores têm percebido a 

importância de se deslocar até onde o público está, seja por questões geográficas ou por 

questões sazonais. Principalmente as construções para entretenimento têm adotado este 

partido e seus proprietários têm percebido seus benefícios, pois elas atraem o público 

com um diferencial, uma imagem arquitetônica de grande beleza. Implícitos na 

desmontabilidade se encontram conceitos importantíssimos atualmente como 

flexibilidade e possibilidade de reúso. 

• Evocação simbólica: Existem tensoestruturas que remetem às tendas utilizadas no 

deserto ou formas arquitetônicas islâmicas, como também velas de navios, ou 

montanhas.  

• Iluminação: O espaço coberto por membranas tensionadas transmite uma iluminação 

natural difusa graças à translucidez do material. A iluminação interior noturna é 

possível e eficiente por causa da alta refletividade da superfície. 

• Energia: O impacto energético de uma tensoestrutura depende da relação entre a 

economia de energia devido à iluminação natural diurna e os maiores gastos com 

aquecimento em regiões onde ele se faz necessário. A avaliação dos gastos com energia 

deve incluir iluminação, aquecimento e resfriamento, além dos custos com os 

equipamentos. 
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ão custo/benefício: Por serem fruto de uma tecnologia sofisticada, as estruturas de 

almente a relação custo/benefício tem imperado, e levando-se 

RUTURAS DE MEMBRANA 

ana tensionadas como: 

• Sombreamento e proteção de grandes espaços abertos ao ar livre;  

• Cobertura de estádios esportivos e piscinas; 

• 

 alguns eventos ou 

depois armazenados no restante, como galpões para 

ue e pavilhões de exposições;       

• Construções permanentes de grande porte como aeroportos, estações e hangares; 

• Baixo peso: Apresentam peso de duas ordens de grandeza menor do que o de estruturas 

em concreto armado e uma ordem de grandeza menor que estruturas convencionais de 

aço.  

• Variabilidade formal e geométrica: Respeitando princípios de projeto podem ser 

criadas inúmeras formas. 

• Relaç

membrana tensionadas normalmente possuem custos elevados em relação a construções 

convencionais. Porém, atu

em conta que estas estruturas podem vencer grandes vãos, ser totalmente dobradas, 

desmontadas e transportadas de acordo com a necessidade; elas são vantajosas para 

determinados casos.       

 

 

2.5. UTILIZAÇÃO DAS EST

 

 

Várias utilizações têm sido dadas às coberturas de membr

Abrigos para entradas ou passeios; 

• Galpões fabris e de depósito; 

• Abrigos temporários e de curta duração necessários em

desmontáveis usados parte do ano e 

armazenagem de picos de estoq
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tos equivocados sobre 

 todas as possibilidades oferecidas por esse 

sistema

s, que melhoraram a 

qualida

 

so é conceber seu uso como alternativa para construções permanentes. 

• Decorações internas de lojas e shoppings. 

A falta de cultura técnica, a dependência de materiais importados (membranas 

sintéticas, determinados cabos e elementos de ancoragem) e os concei

durabilidade são barreiras para a utilização da tensoestrutura no Brasil. 

Poucos profissionais brasileiros conhecem

 construtivo, e o número de especialistas em projetos e cálculos é menor ainda, o que 

mostra um mercado de trabalho com bom potencial de crescimento.  

A boa durabilidade é conseqüência de avanços tecnológico

de das membranas, tornando seu uso próprio para estruturas permanentes, segundo as 

normas internacionais, tendo em vista que não há normas técnicas brasileiras específicas para 

tensoestruturas.  

A opção pela tensoestrutura depende do que o arquiteto deseja em determinado 

projeto, nos aspectos plásticos, de dimensão de vãos, de luminosidade interna ou mesmo em 

projetos de interiores, e a exemplo do que acontece na Europa, no Japão e nos Estados 

Unidos, o consen

 

     

Figura 2.13: Exemplo de estrutura de membrana no Brasil: Restaurante Barra Vento, 
Salvador1. 

                                                 
1 Fotos da autora, em 21/05/2005. 
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1Figura 2.14: Auditório Araújo Viana, Porto Alegre . 

 
Figura 2.15: Foto recente do Auditório Araújo Viana, Porto Alegre2. 

 Em v ais diversos 

2.6. ETAPAS DO PROJETO DE TENSOESTRUTURAS EM MEMBRANA 

É ponto pacífico entre pesquisadores que o projeto de tensoestruturas em membrana 

envolve três etapas distintas: 

      

árias cidades do Brasil têm sido construídas tensoestruturas para os m

fins (Figs. 2.13 e 2.14). No entanto, um problema que também existe em relação às estruturas 

convencionais de concreto e aço é a falta de manutenção e inspeção periódica, como pode ser 

observado comparando as figuras 2.14 e 2.15.  

 

 

 

 

                                           
1 Oliveira (2003). 
2 Foto da autora, em 23/07/2005. 
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• B

. 

usca da forma; 

• Projeto de cortes; e 

• Análise estrutural

 

 

Figura 2.16: Etapas de projeto de uma estrutura de membrana tracionada com cabos.1  

 

 

.6.1. Busca da forma 

Nas tensoestruturas em membrana as características arquitetônicas determinam apenas 

s linhas gerais da forma, enquanto as exigências para a eficiência estrutural definem a forma 

final. 

                                                

2

 

 

a

 

Intenção 
Arquitetônica 

Projeto e  
Análise 

Solução de 
Projeto 

1 Modificado de Figuerola (2004). 
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e apresentar curvatura anticlástica, ou seja, os centros dos raios de curvatura das duas 

direçõe

 aparecer enrugamentos no 

tecido q

ial é dividida em recortes planos correspondentes, com largura e 

omprimento limitados pelas medidas das peças de membrana estrutural comercializadas e 

ela impossibilidade de obter uma planificação perfeita da maioria das superfícies utilizadas. 

Na def

ras em membrana não costumam atender esses requisitos. Como 

elas ge

ser minimizados: a diferença entre a estrutura aproximada e a real, o gasto de tecido e o gasto 

Atendendo às restrições de projeto, uma configuração de equilíbrio para a membrana e 

o correspondente estado de tensão inicial são determinados. Para que a estrutura seja estável, 

ela dev

s principais devem estar em lados opostos da membrana. 

A escolha de uma forma adequada pode trazer várias vantagens: melhor distribuição 

dos esforços na membrana, diminuição do esforço de protensão e até redução no gasto com 

tecido. Se a forma não for cuidadosamente modelada, podem

ue alteram a distribuição de esforços e podem diminuir a vida útil da estrutura. 

 

 

2.6.2. Projeto de cortes  

 

 

A superfície espac

c

p

inição das dimensões dos recortes, considera-se o efeito da relaxação do estado de 

tensão inicial da membrana. 

Se a estrutura apresentar curvatura simples, a planificação é uma tarefa relativamente 

fácil, visto que a forma final é resultante da combinação de várias superfícies de curvatura 

simples. Mas as tensoestrutu

ralmente apresentam dupla curvatura, a planificação exata é impossível, tornando-se 

necessária a adoção de aproximações. 

A definição das peças de corte pode ser abordada como um problema em que devem 
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ões dos rolos, e o alongamento diferenciado na direção 

das fibr

ente. 

 

Com a membrana obtida da montagem dos recortes planos, incluindo-se as estruturas 

análise estrutural considerando-se as devidas combinações de 

arregamento incluindo o peso próprio, pré-tracionamento, cargas acidentais, cargas de vento 

 de neve. 

aplicar uma força externa à membrana, ocorrerá uma deflexão, mudando 

ligeiram

na costura. Nesse processo, é necessário considerar as restrições devido à largura máxima da 

tira do tecido, que é função das dimens

as do urdume e da trama. 

Após a definição das peças de corte é necessário refazer a análise de tensões para levar 

em conta os efeitos ortotrópicos da membrana. Com os resultados dessa análise são feitos 

ajustes nos padrões de corte para melhorar a distribuição de tensões e obter a forma mais 

próxima daquela desejada inicialm

 

2.6.3. Análise estrutural  

 

 

de suporte, realiza-se a 

c

e

Para obter resultados confiáveis de carregamentos dinâmicos de vento em 

tensoestruturas é necessário realizar testes em túnel de vento, visto que nelas não se aplica 

nenhum padrão disponível em normas técnicas e a modelagem numérica é muito complexa. 

Ao 

ente a forma e o raio de curvatura. A tensão em uma direção principal resistirá à carga 

aplicada, enquanto a tensão na direção perpendicular ajudará o sistema a manter a 

estabilidade. 

Uma vez conhecidos deslocamentos e tensões, devem ser feitas verificações que 

comprovem a estabilidade estrutural e para que os limites determinados pelas normas não 
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ressivas na membrana.  

 sustentação da cobertura também é necessária para 

permiti

alizadas com auxílio de modelos físicos em escala 

geomét

ente em escala. Sobre essa 

superfí

No caso de estruturas com dupla-curvatura oposta, à medida que cresce o 

principais e diminui na outra até que 

ão haja mais tração e que a membrana fique folgada. Geralmente, é indesejável que se perca 

 tração em uma área significativa sob a ação de qualquer combinação de carregamento. 

Quando

sejam ultrapassados. Atenção especial também deve ser dada para evitar o aparecimento de 

tensões comp

Para resolver possíveis problemas de tensões pode-se aumentar ou diminuir a 

protensão aplicada aos cabos de borda, buscar uma membrana com outras características 

mecânicas ou mudar a forma da estrutura. 

A análise dos elementos de

r o dimensionamento e detalhamento de toda a estrutura. 

Ainda hoje, em algumas empresas, as duas primeiras etapas do projeto citadas acima, 

busca da forma e projeto de cortes, são re

rica reduzida ou através de moldes definidos de forma empírica. Para definição de 

padrão de corte, por exemplo, a superfície é modelada fisicam

cie são posicionadas tiras de papel, representando as tiras de tecido a serem cortadas. A 

partir dessas tiras são determinadas as geometrias dos pedaços de tecido em escala reduzida 

(Borges, 2004; Oliveira, 2001; Oliveira, 2003). 

 

 

2.7. RECOMENDAÇÕES GERAIS DE PROJETO 

 

 

carregamento, a tração aumenta em uma das direções 

n

a

 surgem regiões com folga, podem ocorrer enrugamentos ou a formação de bolsa, que, 

além de esteticamente indesejáveis, contribuem para fatores deletérios como: a retenção de 
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está ass

Embora as tensoestruturas existam há muito tempo, até por volta de 1968 o projeto de 

ase em modelos físicos. Até hoje, há quem se utilize apenas desses conhecimentos para 

rojetar tensoestruturas. 

o caso do projeto de tensoestruturas em membrana, três grupos se 

destaca

água ou neve; e a propensão a rápidos movimentos como o drapejamento sob a ação do vento. 

Assim, o pré-tracionamento é prescrito de maneira que não ocorram regiões com folga na 

membrana quando a estrutura é submetida aos carregamentos (Shaeffer et al, 1996). 

As tensoestruturas em membrana são projetadas de maneira que se instale um estado 

de tensão uniforme, pois além de um sistema estruturalmente eficiente, isso contribui para a 

durabilidade da membrana e a manutenção do pré-tracionamento inicial ao longo de sua vida 

útil. Por isso, os modelos que fornecem a configuração com superfície de mínima área, que 

ociada a um estado de tensão isotrópica e uniforme, são muito visados.  

 

 

2.8. PRINCIPAIS MÉTODOS NUMÉRICOS PARA ESTRUTURA DE MEMBRANA 

 

 

estruturas de membrana se dava exclusivamente por meio de conhecimentos empíricos e com 

b

p

Com a crescente acessibilidade a computadores, cada vez mais velozes e poderosos, e 

o desenvolvimento de técnicas numéricas eficientes, diversos métodos numéricos foram 

desenvolvidos e estão disponíveis para auxiliar na solução de problemas das mais diversas 

áreas do conhecimento. N

m: o método da densidade de forças (Schek, 1974), o da relaxação dinâmica (Day, 

1965) e o método não-linear dos deslocamentos (Argyris et al, 1974). 
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rama Lights desenvolvido por Arcaro (2006) permite o projeto e a análise de 

nsoestruturas através do método dos elementos finitos, incluindo a membrana, os cabos e 

lementos estruturais de suporte. 

ilíbrio. Assim, não é necessário derivar a matriz de rigidez e 

não im

2.8.1. Lights 

 

 

O prog

te

e

A configuração de equilíbrio estável da estrutura é obtida minimizando-se a energia 

potencial total com o método Quasi-Newton, visto que esse método não exige a resolução do 

sistema típico de equações de equ

porta se a estrutura que está sendo analisada é um mecanismo, caso que ocorre com 

freqüência em tensoestruturas (Arcaro, 2006). 
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3. METODOLOGIA 

 

 

3.1. ESTUDOS DIRIGIDOS 

 

 

O capítulo 2 de Pulino (1991) foi lido para absorção dos conceitos fundamentais sobre 

a análise não linear de estruturas, com enfoque em estruturas reticuladas. 

O texto de Arcaro (2006), que descreve um modelo para a análise não linear de 

membranas com o uso de elementos finitos triangulares de três nós, foi lido para aplicação 

posterior à tensoestrutura em estudo. 

Tendo em vista a complexidade da estrutura em estudo, optou-se pela adoção do 

sistema GiD de pré e pós-processamento de estruturas (geração de malhas de elementos 

finitos e visualização de tensões e deslocamentos), desenvolvido no CIMNE, de Barcelona, 

Espanha. Para utilização do programa, fez-se um estudo dirigido baseado nos manuais de 

utilização e de referência da versão 7 e posteriormente da versão 8, de Ribó (2002, 2005 e 

2006). 

O manual do programa Gmsh de Geuzaine e Remacle (2003) foi estudado e os 

tutoriais disponíveis foram feitos para geração de malha de elementos finitos triangulares de 

três nós no programa citado. 

Para aprender a linguagem de programação Ada 95 utilizada nos programas Lights e 

Membrane, o livro de Lopes (1997), de Skansholm (1997) e do material disponível em Pulino 

(2003) foram estudados. 
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3.2. ANÁLISE DO PROJETO DO CENTRO COMUNITÁRIO 

 

 

Foi feito um levantamento da geometria do projeto da cobertura do Centro 

Comunitário Athos Bulcão/UnB para recuperar os dados a serem usados nos programas GiD, 

Membrane, Lights e Membrane (Borges). 

 

 

3.3. PROGRAMAS 

 

 

O programa GiD foi utilizado para geração de malhas de elementos finitos triangulares 

de três nós e visualização de tensões e deslocamentos. Os programas Membrane, Lights e 

Membrane (Borges) foram usados na obtenção da geometria indeformada tridimensional da 

membrana do Centro Comunitário Athos Bulcão/UnB com visualização dos resultados no 

AutoCad. 

 

 

3.4. ESTÁGIO 

 

 

Para adquirir conhecimentos sobre como são realizadas as etapas de projeto e 

construção de tensoestruturas foi feito um estágio voluntário na Pistelli Engenharia, em São 

Paulo, empresa responsável pela construção do Centro Comunitário Athos Bulcão/UnB. 
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3.5. DESENVOLVIMENTO DE PROGRAMAS E PROCEDIMENTOS EM ADA 95 

 

 

Os programas GiDMembrane, GiDLights e MembraneLights foram elaborados para 

permitir a geração de arquivos de entrada e intercâmbio de resultados entre o Membrane, o 

Lights e o GiD (pré e pós-processamento). 

Um procedimento desenvolvido no programa Membrane foi adaptado e aprimorado 

para ser implementado no Lights. Este procedimento permite que o resultado do cálculo de 

tensões na membrana desenvolvido pelo programa utilizado seja visualizado dentro do 

ambiente GiD de pós-processamento, facilitando a análise da tensoestrutura, no caso do 

Centro Comunitário Athos Bulcão/UnB. 

Os resultados obtidos nos elementos de cabo e de pórtico foram incluídos no procedimento 

GiD de pós-processamento desenvolvido para o programa Lights. A versão do programa 

Lights que apresenta essa possibilidade de visualização de resultados de elementos de 

membrana, cabo e pórtico no ambiente GiD de pós-processamento passou a ser chamada 

LightsGiD (Fig. 3.1). 
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Figura 3.1: Esquema dos programas elaborados (azul) e modificado (verde). 

GiDLights 
 

Criação de um arquivo de entrada  
do Lights a partir da malha de 

elementos finitos gerada no GiD.  

Cálculo de tensões e deslocamen-
tos. Utilização de elementos de 

cabo, membrana e pórtico.

LightsGid 
 

GiDMembrane 
 

Criação de um arquivo de entrada  
do Membrane a partir da malha de 
elementos finitos gerada no GiD.  

GiD 
Pré-Processamento 

 
Geração de malhas de  

elementos finitos. 

Membrane 
 

Definição da forma da  
tensoestrutura apenas com  
elementos de membrana. 

MembraneLights 
 

Geração de um arquivo de entrada  
para o Lights a partir de resultados  

  obtidos no Membrane.  

GiD 
Pós-Processamento 

 
Visualização de resultados  

de tensões e deslocamentos. 
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3.6. ANÁLISE DE TENSÕES E DESLOCAMENTOS DA TENSOESTRUTURA DE 

COBERTURA DO CENTRO COMUNITÁRIO DA UNIVERSIDADE DE BRASÍLIA 

 

 

Foi feita análise dos resultados dos cálculos do programa Lights de tensões e 

deslocamentos da membrana e dos cabos que compõe a tensoestrutura de cobertura do Centro 

Comunitário Athos Bulcão/UnB no ambiente GiD de pós-processamento e no AutoCad.  

Foram impostos carregamentos distribuídos em todos os elementos da membrana simulando 

um carregamento estático de vento de sobrepressão e de sucção de 75 kgf/m2. Depois disso os 

cabos de borda foram tracionados, em busca de uma configuração sem elementos de 

membrana submetidos a esforços de compressão. 

 

 

3.7. ELABORAÇÃO DO MANUAL PARA UTILIZAÇÃO DOS PROGRAMAS 

DESENVOLVIDOS 

 

 

Para facilitar a utilização dos programas desenvolvidos e aprimorados, foi elaborado 

um manual, apresentado no Apêndice A, com uma tensoestrutura em forma de parabolóide 

hiperbólico como exemplo.  

 No CD incluído no Apêndice B estão os arquivos executáveis e os que contém o 

código fonte dos programas desenvolvidos e utilizados, o manual de utilização, os arquivos 

gerados no exemplo que faz parte do manual e ainda estão disponíveis seis exemplos de 

estruturas encontrados em Arcaro (2003) que podem ser analisados no LightsGiD. 
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4. RESULTADOS E DISCUSSÃO 

 

 

Após o levantamento da geometria do Centro Comunitário da UnB foi elaborada uma 

planta baixa da estrutura no AutoCad posteriormente levada para o GiD para obtenção da 

malha de elementos finitos triangulares de três nós (Fig. 4.1) correspondente à projeção 

horizontal da forma desejada. 

 
Figura 4.1: Malha de elementos finitos triangulares de três nós obtida no GiD. 

A partir da malha plana (Fig. 4.1), no programa Membrane obteve-se a geometria 

indeformada em três dimensões com visualização dos resultados no AutoCad (Fig. 4.2) e no 

GiD (Figs. 4.3, 4.4 e 4.5) aplicando deslocamentos prescritos aos nós que correspondem aos 

pontos de apoio dos mastros. As posições dos nós livres foram encontradas através da solução 

do sistema não linear da estrutura. Os deslocamentos dos nós mostrados nas figuras 4.5, 4.19, 

4.23 e 4.27 foram calculados a partir da cota zero.  

 
 

 

 

 

 
Figura 4.2: Geometria indeformada em três dimensões obtida com o Membrane visualizada 

no AutoCad. 
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Figura 4.3: Tensão principal 1 no GiD (kPa). 

 

 
Figura 4.4: Tensão principal 2  no GiD (kPa). 

 

 
Figura 4.5: Deslocamentos dos nós na direção z no GiD (m). 

 
Com a utilização do programa Membrane conseguiu-se uma aproximação da forma da 

estrutura real, mas a região central apresentou uma depressão que não é compatível com a 

realidade.  

 



 30

Aumentando o módulo de elasticidade da malha no mesmo programa obteve-se uma 

depressão menor no centro da estrutura.   

A partir da observação que a região central do tecido assume forma inicial com 

curvatura indesejável como elemento de cobertura (concavidade para cima) e que o programa 

Membrane não permite a utilização de cabos, e estes contribuem para solucionar o problema 

citado, decidiu-se tentar, na obtenção da forma inicial, a inclusão de cabos de borda (que seria 

inevitável na análise real de tensões) com a utilização do programa Lights (Fig. 4.6). 

No Lights foi possível adicionar cabos em toda a borda da malha, reduzindo ainda 

mais a depressão central. Observou-se que com o aumento da seção do cabo a aproximação da 

forma obtida com a real é ainda maior. 

A numeração dos cabos (Tab. 4.1) citada ao longo do texto refere-se aos dados 

fornecidos por Arcaro (2006) no primeiro exemplo do programa Lights, dentro do arquivo de 

entrada material.txt.       

Tabela 4.1: Dados de entrada dos cabos no Lights. 
Número do 

cabo 
Módulo de 

Young 
(kPa) 

Peso/unidade de 
comprimento 

(kN/m) 

Área da seção 
transversal  

(m2) 

Carga última 
(kN) 

1 1,568x108 7,994154x10-3 9,627400x10-5 1,186878x102

6 1,470x108  2,420796x10-2 2,920180x10-4 3,493700x102

15 1,225x108 1,004598x10-1 1,234024x10-3 1,527526x103

 

 
Figura 4.6: Resultado do Lights com cabo 1 no AutoCad. 
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As partes da cobertura que se apresentam em vermelho (Fig. 4.6) são aquelas 

submetidas à compressão, ou seja, o tecido está frouxo. As outras regiões estão sob esforço de 

tração, condição desejável neste tipo de estrutura. 

Como a inclusão de cabos de borda não foi suficiente para que a curvatura da região 

central da estrutura apresentasse concavidade para baixo, decidiu-se gerar no GiD uma malha 

plana simétrica em relação a um eixo orientado segundo a maior dimensão e outro ortogonal 

ao primeiro. 

Utilizou-se apenas um quarto da planta baixa da estrutura (Fig. 4.7) para geração de 

uma malha de elementos finitos triangulares de três nós no GiD rebatida para obtenção da 

malha inicial simétrica completa (Fig. 4.8). 

 
Figura 4.7: Um quarto da superfície de membrana para gerar a malha a ser espelhada 

no GiD. 

 
Figura 4.8: Malha simétrica de elementos finitos triangulares de três nós obtida no GiD. 

 Foi utilizado o programa Membrane para obtenção da geometria indeformada em três 

dimensões a partir da malha simétrica com visualização dos resultados no AutoCad (Fig. 4.9). 
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Figura 4.9: Geometria indeformada obtida no Membrane com visualização no AutoCad. 

A geometria indeformada obtida com o Membrane a partir da malha simétrica       

(Fig. 4.9) apresentou na região central uma concavidade menos acentuada do que aquela 

observada com a malha inicial (Fig. 4.2). Os resultados foram ainda melhores quando a malha 

simétrica foi utilizada no Lights na geração da geometria indeformada (Figs. 4.10 e 4.11). 

  
Figura 4.10: Resultado do Lights com cabo 1 no AutoCad. 

 
Figura 4.11: Resultado do Lights com cabo 15 no AutoCad. 
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Figura 4.12: Resultado do Lights com cabo 15 renderizado no AutoCad. 

 Observou-se uma redução no número de elementos da malha submetidos à 

compressão quando se compara a geometria indeformada gerada no Lights com cabo 1 a 

partir da malha sem (Fig. 4.6) e com simetria (Fig. 4.10). 

Com o aumento do diâmetro dos cabos de borda praticamente toda a cobertura está 

tracionada e a concavidade da região central está para baixo, condição necessária em 

coberturas (Fig. 4.11).  

O programa Membrane (Borges) que trata a malha como material hiperelástico foi 

utilizado para geração da geometria indeformada com visualização de resultados no AutoCad 

(Fig. 4.13). 

 
Figura 4.13: Resultado do Membrane (Borges) no AutoCad. 

No Membrane (Borges) foi obtida uma forma da estrutura a partir da malha simétrica 

com arcos laterais mais altos (Fig. 4.13) do que os da estrutura construída na UnB então foi 
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feita uma redução de um terço da flecha nos arcos de borda da malha simétrica no GiD     

(Fig. 4.14) e uma nova geometria indeformada foi gerada (Fig. 4.15). 

 
Figura 4.14 - Malha simétrica de elementos finitos triangulares de três nós com flecha 

reduzida obtida no GiD. 

 
Figura 4.15: Resultado do Membrane (Borges) no AutoCad. 

 
Figura 4.16: Resultado do Membrane (Borges) com renderização no AutoCad. 

Não foi possível comparar os resultados obtidos com os do autor do projeto pois a 

Prefeitura do Campus da UnB não disponibilizou esse material (declarou não ter em seu poder 

projeto executivo ou memória de cálculo). 
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A tentativa de utilizar o programa Gmsh na geração de malhas de elementos finitos 

não obteve muito sucesso devido à dificuldade de entendimento do manual e dos tutoriais 

disponíveis e pelo programa não ser de fácil utilização. 

Os tutoriais e exercícios disponíveis para aprendizagem da linguagem de programação 

Ada 95 foram executados sem grandes dificuldades permitindo uma rápida absorção dos 

conhecimentos necessários para utilização da linguagem. 

Os parâmetros de entrada de dados da membrana foram sugeridos por Arcaro, 

conforme utilizado em empresas de projeto de tensoestruturas: 

• Módulo de elasticidade * espessura: 700 kN/m; 

• Coeficiente de Poisson: 0,20; 

• Massa: 1050 g/m2; 

A adaptação do procedimento GiD disponível apenas no programa Membrane é de 

grande importância visto que o programa citado permite análise apenas da membrana e o 

Lights realiza cálculo de tensões e deslocamentos não só da membrana mas dos mastros e 

cabos de borda. 

Após a adaptação citada acima estar concluída e os programas de intercâmbio de 

arquivos de entrada de dados e resultados entre o GiD, o Lights e o Membrane estarem 

prontos, foi gerada uma nova malha simétrica de elementos finitos triangulares de três nós 

(Fig. 4.17) com elementos com a medida lateral do triângulo duas vezes menor do que aqueles 

gerados anteriormente (Fig. 4.8) mas com o mesmo contorno externo, visto que agora a 

geração de cabos e a atribuição de materiais ficou bem mais rápida com os programas 

GiDMembrane, GiDLights e MembraneLights. 
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Figura 4.17: Malha simétrica de elementos finitos triangulares de três nós obtida no GiD. 

Depois foram impostos deslocamentos aos nós que correspondem aos pontos de apoio 

dos mastros no programa Membrane para obtenção da geometria indeformada (Fig. 4.18). 

 
Figura 4.18: Geometria indeformada obtida no Membrane com visualização no AutoCad. 

Como os elementos da malha foram reduzidos de tamanho, a forma da membrana com 

a concavidade voltada para cima no centro da estrutura (Figs. 4.18 e 4.19) ficou mais bem 

definida do que com a malha gerada anteriormente (Fig. 4.9).  

 
Figura 4.19: Deslocamentos dos nós no GiD (m), resultado do Membrane. 
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Para reduzir a depressão central, a partir da malha plana, foram impostos 

deslocamentos aos nós de apoio nos mastros no LightsGiD (versão do Lights desenvolvida 

que permite visualização de resultados no ambiente GiD pós-processamento), com cabo 15 na 

borda, para obter uma geometria indeformada mais compatível com a realidade (Fig. 4.20). 

 
Figura 4.20: Visualização no AutoCad da geometria inicial sobre a qual foram aplicados os  

carregamentos. 

Foram aplicados dois carregamentos distribuídos ortogonais à superfície dos 

elementos de membrana de 75 kgf/m2 (0,7355 kN/m2) com sentidos opostos para simular os 

carregamentos de sucção e sobrepressão na membrana com cabos de borda 6 sem pré-

tracionamento.  

Os resultados da análise feita pelo programa LightsGiD com sucção podem ser 

observados no AutoCad (Fig. 4.21) e no GiD (Figs. 4.22 a 4.25), da mesma forma foram 

apresentados os resultados com sobrepressão (Figs. 4.26 a 4.29). 

 
Figura 4.21: Visualização no AutoCad da configuração deformada da membrana com cabo 6, 

resultado do LightsGiD, sucção. 
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Figura 4.22: Força atuando nos cabos de borda 6 com sucção e sobrepressão (kN). 

 
Figura 4.23: Deslocamentos dos nós com cabo 6 sem pré-tracionamento, sucção (m). 

 
 

 
Figura 4.24: Tensão principal 1 nos elementos da membrana com a estrutura submetida a 

sucção e com os cabos sem pré-tracionamento (kPa). 
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Figura 4.25: Tensão principal 2 nos elementos da membrana com a estrutura submetida a 

sucção e com os cabos sem pré-tracionamento (kPa). 

 
Figura 4.26: Visualização no AutoCad da configuração deformada da membrana com cabo 6, 

resultado do Lights, sobrepressão. 
 

 
Figura 4.27: Deslocamentos dos nós com cabo 6 sem pré-tracionamento, sobrepressão (m). 
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Figura 4.28: Tensão principal 1 nos elementos da membrana com a estrutura submetida a 

sobrepressão e com os cabos sem pré-tracionamento (kPa). 

 
Figura 4.29: Tensão principal 2 nos elementos da membrana com a estrutura submetida a  

sobrepressão e com os cabos sem pré-tracionamento (kPa). 

Nos gráficos de resultados de carregamentos mostrados acima (Figs. 4.21 a 4.29) 

observa-se uma simetria diagonal. De início cogitou-se a possibilidade disso ser conseqüência 

do coeficiente de Poisson, pois a membrana se deforma de maneira diferente na direção da 

urdidura e da trama, mas após alguns testes em que foram anulados os efeitos do coeficiente 

de Poisson, verificou-se que a causa de tal simetria não era essa. 

 Como a análise não linear convergiu para uma configuração de equilíbrio, era possível 

que esse resultado apresentado fosse apenas uma das possíveis configurações de equilíbrio 

encontradas. Para melhorar esse resultado é recomendável fazer testes com várias unidades 

diferentes nos arquivos de entrada de dados para o programa LightsGiD, visto que na análise 
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não linear, a ordem de grandeza dos valores utilizados nos cálculos influi na configuração de 

equilíbrio obtida. 

Depois de tentar solucionar o problema da simetria diagonal, conforme descrito 

anteriormente, sem sucesso, foi mandado um correio eletrônico para uma lista que troca 

informações e dúvidas sobre a utilização do GiD. Nesta lista participam também engenheiros 

ligados ao CIMNE, centro onde o programa foi desenvolvido. A resposta obtida foi que o 

GiD versão 7.2, a mais nova versão disponível naquele momento, ao espelhar um quarto da 

malha para ir formando a malha completa simétrica, espelhava também o vetor normal dos 

elementos, invertendo seu sentido em relação ao original. Como esse vetor é utilizado para 

dar a correta direção e sentido das cargas aplicadas no LightsGiD, cada pedaço de um quarto 

de malha apresentou uma resposta diferente ao mesmo carregamento. 

Para que não fosse necessário espelhar a membrana mas fosse possível trabalhar com 

simetria, descobriu-se que ao colocar linhas guias dividindo a superfície (Fig. 4.30) onde a 

malha seria gerada, era possível gerar toda a malha de uma só vez com simetria (Fig. 4.17), 

evitando a inversão dos vetores normais dos elementos. 

 
Figura 4.30: Superfície com linhas guias para geração de malha de elementos finitos. 

Os dois carregamentos distribuídos ortogonais à superfície dos elementos de 

membrana de 75 kgf/m2 (0,7355 kN/m2) com sentidos opostos foram aplicados novamente, 

para simular os carregamentos de sucção e sobrepressão na membrana com cabos de borda 6 

com pré-tracionamento.  
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A visualização dos resultados calculados pelo LightsGiD foi feita no AutoCad       

(Fig. 4.31) e no GiD (Figs. 4.32 a 4.34) para o carregamento de sucção, da mesma forma 

foram apresentados os resultados para o carregamento de sobrepressão (Figs. 4.35 a 4.38). 

  
Figura 4.31: Visualização no AutoCad da configuração deformada da membrana com cabo 6, 

resultado do Lights, sucção. 

  
Figura 4.32: Força atuando nos cabos de borda 6 sob sucção (kN). 

  
Figura 4.33: Tensão principal 1 nos elementos da membrana com a estrutura submetida a 

sucção e com os cabos com pré-tracionamento (kPa). 
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Figura 4.34: Tensão principal 2 nos elementos da membrana com a estrutura submetida a 

sucção e com os cabos com pré-tracionamento (kPa). 
 

  
Figura 4.35: Visualização no AutoCad da configuração deformada da membrana com cabo 6, 

resultado do Lights, sobrepressão. 
 

 
Figura 4.36: Força atuando nos cabos de borda 6 sob sobrepressão (kN). 
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Figura 4.37: Tensão principal 1 nos elementos da membrana com a estrutura submetida a 

sobrepressão e com os cabos com pré-tracionamento (kPa). 
 

  
Figura 4.38: Tensão principal 2 nos elementos da membrana com a estrutura submetida a  

sobrepressão e com os cabos com pré-tracionamento (kPa). 

O problema da simetria diagonal mostrado anteriormente (Figs. 4.21 a 4.29) foi 

resolvido com a nova estratégia de geração da malha no GiD versão 7.2 (Fig. 4.30). 

Atualmente existe uma nova versão do GiD, 8.0, que não inverte mais o vetor normal 

quando o usuário espelha uma malha de elementos finitos. Essa versão espelha a malha, mas 

mantém o vetor normal na mesma direção e sentido da malha original, permitindo a geração 

de apenas um quarto da malha como foi tentado inicialmente para o Centro Comunitário e 

mostrado no exemplo do parabolóide hiperbólico no Manual (Apêndice A). 

Aplicando pré-tracionamento, os cabos permanecem tracionados quando submetidos 

aos dois carregamentos, de sucção e sobrepressão (Figs. 4.32 e 4.36). 
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Já os elementos de membrana apresentaram grandes áreas de compressão (Figs. 4.31, 

4.34, 4.35 e 4.38) mesmo tendo aplicado pré-tracionamento nos cabos para procurar manter a 

estrutura toda sempre tracionada, condição essencial para este tipo de estrutura. 

  Para que os elementos de membrana não sejam submetidos a esforços de compressão é 

necessário obter os parâmetros reais da membrana e dos cabos de borda utilizados no Centro 

Comunitário Athos Bulcão/UnB além de mais informações do projeto, incluindo os mastros e 

detalhes de fixação da membrana (Fig. 4.39). 

    
(a)                                         (b) 

Figura 4.39: Detalhes de fixação da membrana:  
(a) nos mastros laterais e (b) nos mastros principais. 

 As figuras 4.40, 4.41 e 4.42 mostram um modelo computacional com elementos de 

membrana, cabo e mastro e detalhes de fixação do Centro Comunitário Athos Bulcão/UnB no 

ambiente GiD de pós-processamento gerado através do LightsGiD com dados hipotéticos. 

 
Figura 4.40: Vista superior e inferior do modelo com elementos de membrana (verde), de 

cabo (azul) e mastro (magenta). 
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Figura 4.41: Vista lateral e detalhe de fixação da membrana no mastro lateral. 

 
Figura 4.42: Vista parcial do modelo com elementos de membrana, cabo e mastro além de 

visualização de detalhes de fixação da membrana nos mastros principais. 
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5. CONCLUSÕES 

 

 

As duas formas da estrutura em estudo obtidas mais próximas da realidade foram 

aquelas geradas pelo programa Lights (Fig. 4.20) e pelo programa Membrane (Borges)     

(Fig. 4.15). Enquanto o programa Membrane (Borges) não apresentar possibilidade de inserir 

cabos de borda, recomenda-se utilizar a forma obtida com o Lights para futuro estudo de 

tensões sob carregamento externo. 

A diferença entre os resultados obtidos com os programas Lights e Membrane 

(Borges) resulta da utilização de modelos diversos para tratamento da estrutura. O Lights 

adota o modelo CST – Constant Strain, onde o material é elástico linear, submetido a um 

estado plano de tensões (Fig. 4.12). No Membrane (Borges) o modelo usado é o Neo 

Hookeano, considerando a malha como material hiperelástico (Fig. 4.16), evitando 

angulações entre os elementos triangulares. 

 Os resultados obtidos impondo carregamento estático de vento e pré-tracionamento 

mostram o quanto é importante conhecer os parâmetros que definem as características 

mecânicas da membrana, dos cabos e dos mastros a serem utilizados, e como é complexa a 

análise desse tipo de estrutura, sendo necessária a realização de testes em túnel de vento para 

que seu efeito possa ser avaliado adequadamente. 

Os programas GiD, Membrane e Lights foram integrados através dos programas 

GiDMembrane, GiDLights e MembraneLights. Por meio de alguns procedimentos novos e 

outros adaptados, o Lights passou a permitir a visualização de resultados na membrana, nos 

cabos e nos elementos de pórtico no ambiente GiD de pós-processamento, essa nova versão é 

chamada LightsGiD.  
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6. SUGESTÕES PARA TRABALHOS FUTUROS 

 

 

Alguns temas para futuros trabalhos de pesquisa em tensoestruturas: 

• Determinação do padrão de corte da membrana buscando uma distribuição mais 

uniforme de tensões e uma redução nas perdas do tecido; 

• Efeitos das costuras na distribuição de tensões na membrana após a montagem da 

estrutura. 

• Experimentos em túnel de vento com tensoestruturas para avaliar melhor os esforços 

provocados pelo vento; 

• Experimentos com diferentes membranas para determinar suas características, como 

tensões de ruptura, módulo de Elasticidade, coeficiente de Poisson, desempenho 

acústico, durabilidade, resistência ao fogo, entre outras. 
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APÊNDICE A – MANUAL 

 

 

 Este manual foi elaborado para facilitar a utilização dos programas Membrane, Lights, 

GiD, GiDMembrane, GiDLights, MembraneLights e LightsGiD, assim como a geração dos 

seus arquivos de entrada e o intercâmbio de resultados entre eles. Ao longo do texto é feito 

um exemplo passo-a-passo de um parabolóide hiperbólico. O manual é apresentado em inglês 

para facilitar a manutenção de um padrão de nomenclaturas e comandos já existentes nos 

programas Membrane, Lights e GiD. 

 

 

A.1. GENERAL INFORMATION 

 

 

Files with the extensions: 

⎯ .ads and .adb are program source code files written in Ada95. 

⎯ .exe are executable files of the programs. If the user wants just to run the program, the 

.exe file is the only one necessary. 

⎯ .post.msh and .post.res are GiD postprocess files, where the results may be seen in 

GiD. 

⎯ .gid are GiD preprocess files, where the finite element mesh was generated. 

A consistent system of units must be used during the whole process. 

All the programs used, developed or updated in this master thesis (Fig. A.1) are 

available in the CD in a folder called “Programs” with the same name of the program. 
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 GiD is a pre and postprocess program available at http://gid.cimne.upc.es/. This master 

thesis used GiD version 8.0. This version can be installed from the CD folder Program/GiD8 

where the user can find also Reference and User Manuals. 

 Membrane and Lights are available at http://www.arcaro.org/tension/. The Membrane 

version included in the CD folder “Membrane” was updated to work together with GiD 

version 8.0. The theory developed by Arcaro for this computer code is explained in “A simple 

procedure for shape finding and analysis of fabric structures” in the CD folder 

Program/Membrane, the file with this article is called “membrane.pdf” or “membrane.doc”. 

GiDMembrane is a program developed in this master thesis that makes it easier for the 

user that generated a mesh inside GiD to create the input file to run Membrane (input.txt). 

The program MembraneLights helps the user that wants to run Lights or LightsGiD 

starting with the deformed mesh obtained from Membrane to create one of the input files 

necessary to run Lights or LightsGiD (structure.txt). It was also developed in this master 

thesis. 

 GiDLights is also a program developed in this master thesis to create one of the input 

files necessary to run Lights or LightsGiD (structure.txt) from a mesh generated in GiD.  

 LightsGiD is a version of Lights with some procedures developed in this master thesis 

that create the files necessary to see the results inside GiD Postprocess. 

 The files created in the example shown in this manual are in the CD folder “Example”, 

separated in folders with the name of the programs.   
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Figure A.1: Scheme of the developed (blue) and modified (green) programs.  
 

GiDLights 
 

Creation of an input file for Lights 
from a mesh generated in GiD.  

GiDMembrane 
 

Creation of the input file for 
Membrane from a mesh generated 

in GiD. 

GiD 
Preprocess 

 
Finite element mesh generation.  

Membrane 
 

Form finding of the tension 
structure only with membrane 

elements.

MembraneLights 
 

Creation of an input file for Lights 
from results calculated in 

Membrane. 

LightsGid 
 

Stress and displacement calculus 
with cable, frame and membrane 

elements.

GiD 
Postprocess 

 
View of stress and displacement 

results.
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A.2. GiD PREPROCESS 

GiD 
Preprocess 

 

This part of the manual will show how to generate a finite element mesh using GiD. 

There are several ways to provide GiD the contour of the surface that the user wants to 

generate a mesh on. Two possibilities will be shown here. 

 It is recommended to use GiD version 8.0, available at http://gid.cimne.upc.es/ . This 

version maintains the normal vector of a mirrored mesh in the same direction of the original 

mesh. The older versions reverse the direction of the normal vector when a mesh is mirrored, 

causing problems when loading the structure. 

An example will be done while the procedures are explained. Everything related to 

this example will be written in italic. When working in your own project, this information in 

italic will be replaced by your own data. The menus inside the programs will be written in 

bold. 

 Since this example is symmetric, only one fourth of the mesh will be generated and 

then it will be mirrored. 

 

  

A.2.1. First option: Import the membrane contour drawing from AutoCAD 

 

 

If the membrane contour already exists in AutoCAD (Contour.dwg) or the user prefers 

to draw in this software (Fig. A.2), when the drawing is finished it is only necessary to go to 

File → Save as... and at the window that opens, type a file name and change the file type to 

.dxf (Contour.dxf). Then click on Save. 
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Figure A.2: A view of what was drawn in AutoCAD with the corner coordinates. 

Open GiD and go to Files → Import → DXF and select the file that was saved in 

AutoCAD (Contour.dxf). 

 

 

A.2.2. Second option: Draw the membrane contour inside GiD 

 

 

Open GiD and go to Geometry → Create → Straight Line. Enter the point 

coordinates.  

 -2.5,-2.5,0    0,-2.5,0 and press ENTER.  Press ESC and go to Geometry → Create → 

Straight Line. Click on the left point and then Join. Enter the following point coordinates:     

-2.5,0,0   0,0,0 and press ENTER then click on the point on the bottom right corner and click 

Join. Press ESC twice. 

(0.0,0.0,0.0) (-2.5,0.0,0.0) 

(-2.5,-2.5,0.0) (0.0,-2.5,0.0) 
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A.2.3. After importing the membrane contour from AutoCAD or drawing it inside GiD 

 

 

Inside GiD, go to Geometry → Create → NURBS Surface → By contour. Click on 

the contour lines and press ESC twice (Fig. A.3).  

 
Figure A.3: NURBS Surface created. 

To see node, line or surface numbers, go to View → Label and choose the desired 

option (Fig. A.4). 

 
Figure A.4: Node, line and surface numbers. 

To generate a mesh including membrane and cable elements, go to Mesh → Mesh 

criteria → Mesh → Lines. Click on the lines that represent cables (1 and 2). Press ESC and 

then Mesh → Mesh criteria → Mesh → Surfaces. Click on the surface with the mouse and 

then press ESC. Now go to Mesh → Generate Mesh and type the size of the elements (0.4). 

Click on OK twice. 

 To see node or element numbers, go to View → Label and choose the desired option 

(Fig. A.5). 
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Figure A.5: Mesh view with node (black), cable and membrane elements (green) numbers. 

Go to View → Mode → Geometry 

To mirror the surface, go to Utilities → Copy and enter the information shown below 

(Fig. A.6). 

 
Figure A.6: Instructions to mirror the geometry, first step. 

Click on Select and with the mouse select the whole surface. On the bottom of the 

Copy window, click on Finish. 
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 Go to the menu View → Zoom → Frame in order to see the result.  

 Repeat this procedure to mirror again, entering the information shown in the Copy 

window below (Fig. A.7). 

  
Figure A.7: Instructions to mirror the geometry, second step. 

 Click on Select and with the mouse select the whole surface. On the bottom of the 

Copy window, click on Finish. Close the Copy window by clicking on Cancel. 

 Go to the menu View → Zoom → Frame in order to see the result (Fig. A.8).  

 
Figure A.8: Complete geometry. 
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 Go to View → Mode → Mesh. 

 To mirror the mesh, go to Utilities → Copy and enter the information shown in the 

following figure (Fig. A.9). 

  
Figure A.9: Instructions to mirror the finite element mesh, first step. 

 Click on Select and with the mouse select the whole mesh. On the bottom of the Copy 

window, click on Finish. 

 Go to the menu View → Zoom → Frame in order to see the result.  

 Repeat this procedure to mirror again, entering the information shown in the Copy 

window in the next page (Fig. A.10). 
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Figure A.10: Instructions to mirror the finite element mesh, second step. 

 Click on Select and with the mouse select the whole mesh. On the bottom of the Copy 

window, click on Finish. Close the Copy window by clicking on Cancel. 

 Go to the menu View → Zoom → Frame in order to see the result (Fig. A.11).  

 It is very important to renumber nodes and elements after the mesh is ready, 

Utilities → Renumber then click OK. 

                     139            185 

 

 
 
 
 
 
 
 
    1           138 

Figure A.11: Complete mesh with corner node numbers. 

 To save, Files → Save as... and type the file name (Example.gid). Click on Save. 
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 To generate the data file that will be used to create Membrane, Lights or LightsGiD 

input files, go to Files → Export → Text data report... and write the file name 

(Example.txt). Click on Save. 

 To see the normal vectors, View → Normals → Elements select the elements with 

the mouse and if the user would like to have a view from a different angle, View → Rotate 

→ Trackball (Fig. A.12). When finished, press ESC twice. 

 
Figure A.12: Generated mesh with normal vectors. 

 Close GiD, go to Files → Quit. 
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A.3. GiDMEMBRANE 

GiD  

GiDMembrane 
Preprocess 

 

The program GiDMembrane makes it easier for the user that generated a mesh inside 

GiD to create the input file to run Membrane (input.txt). 

Inside the Windows Explorer, copy the text data report file exported from GiD 

(Example.txt) into the same folder were gidmembrane.exe is. Click on gidmembrane.exe, a 

window will open where the required information should be typed: 

Please enter the name of the text data report file exported from GiD (without extension). 

Example 

Please write the following values:  
lstol, maxls, mntol, mnref, maxminor and maxlist. 

0.1      20    0.000001   0          6000                   3 

⎯ lstol: controls the accuracy of the line search. It must lie in the range 0.0  ≤ lstol < 1.0. 

Decreasing this value tends to increase the accuracy of the line search. It is usually 0.1. 

⎯ maxls: The maximum number of cubic interpolations allowed in the line search. It 

must be greater than one. It is usually 20. 

The iterations terminate if the infinity norm of the residue becomes less than or equal 

to maxnorm, which is calculated as: maxnorm = mntol * mnref. 

 If mntol is specified as a non-positive value, it is replaced by 0.001. If mnref is 

specified as a non-positive value, it is replaced by the infinite norm of the residue, evaluated 

with all displacements equal to zero.  

⎯ maxminor: The maximum number of iterations allowed. It must be greater than zero. 

It is usually ten times the number of degrees of freedom. 
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⎯ maxlist: the number of BFGS corrections kept. These corrections are stored separately 

on a doubly linked circular list. Used only with the limited memory BFGS method. It is 

usually between 3 and 20. 

Please write the following values:  
stiffness, poisson and density 

    500         0.2               0 

⎯ stiffness: The membrane stiffness (Young’s modulus * thickness). 

⎯ poisson: The Poisson’s ratio associated with the membrane material. 

⎯ density: Weight per unitary area. 

How many nodes will be displaced? 

4 

Please write the node number and the displacement in x, y and z directions – do this for 
each node. 
 

1 -1.0 -1.0 3.0

138 1.0 -1.0 5.0

139 -1.0 1.0 5.0

185 1.0 1.0 3.0

Would you like to apply nodal forces? Y=Yes    N=No 

N 

The following questions will only appear if the answer to the previous question is Y. 

How many nodes will have applied forces? 

Please write the node number and the forces in x, y and z directions – do this for each 
node. 

 

The input.txt file that will be used to run Membrane will be created automatically in 

the same folder where gidmembrane.exe is. If the user would like to check anything or if there 

were any mistakes while entering the data asked before, the file input.txt can be opened with 

Note Pad or Word Pad. 
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A.4. MEMBRANE 

 

 To run Membrane, copy the file input.txt into the same folder where membrane.exe is. 

Click on membrane.exe. The following files with the results will be created: output.txt, 

autocad.scr, results.post.msh and results.post.res.  

 Open AutoCAD and go to Tools → Run Script... click on autocad.scr. The deformed 

mesh will appear (Fig. A.13) and the user can turn on another layer to see also the 

undeformed mesh (Fig. A.14). 

 
Figure A.13: Deformed mesh top view in AutoCAD. 

 
Figure A.14: Deformed and undeformed meshes in AutoCAD. 

GiD  

Preprocess 
GiDMembrane 

 

Membrane 
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A.5. GiD POSTPROCESS 

 

To see Membrane output results in GiD (Fig. A.15), open GiD and go to Files → 

Postprocess, then Files → Open and click on results.post.res.  

 

 

 

 

Figure A.15: Deformed mesh top view in GiD Postprocess. 

It is possible to view different angles with View → Rotate → Trackball (Fig. A.16). 

 
Figure A.16: Rotated deformed mesh top view in GiD Postprocess. 

To see the results, go to the menu View results and choose between the options 

available that show stress or displacements (Fig. A.17). 

 

 

 

 
Figure A.17: One of the results possibilities: Y Displacement. 

 

 

GiD 
Preprocess 

 

GiDMembrane 
 

Membrane GiD 
Postprocess 
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A.6. MEMBRANELIGHTS 

 

The program MembraneLights makes it easier for the user that wants to run Lights or 

LightsGiD starting with the deformed mesh obtained from Membrane to create one of the 

input files necessary to run Lights or LightsGiD (structure.txt). 

 To understand better what is asked while running MembraneLights, what is written in 

the file structure.txt and also the information necessary in the other two input files needed for 

Lights or LightsGiD, material.txt and loading.txt, please read Lights user´s manual in this CD 

at Programs/Lights/manual.pdf or Programs/Lights/manual.doc. 

  Inside the Windows Explorer, copy the text data report file exported from GiD 

(Example.txt) and the output.txt file from Membrane into the same folder were 

membranelights.exe is. Click on membranelights.exe, a window will open where the required 

information should be typed: 

Please enter the name of the text data report file exported from GiD (without extension). 

Example 

Were cable elements generated in GiD?   Y=Yes   N=No 

Y 

Please write the following values:  
lstol, maxls, mntol, mnref, maxminor and maxlist. 

0.1      20      0.0001    0          10000                   3 

⎯ lstol: controls the accuracy of the line search. It must lie in the range 0.0  ≤ lstol < 1.0. 

Decreasing this value tends to increase the accuracy of the line search. It is usually 0.1. 

⎯ maxls: The maximum number of cubic interpolations allowed in the line search. It 

must be greater than one. It is usually 20. 

GiD 
Preprocess 

 

GiDMembrane 
 

 

Membrane 
 

MembraneLights 
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The iterations terminate if the infinity norm of the residue becomes less than or equal 

to maxnorm, which is calculated as: maxnorm = mntol * mnref. 

 If mntol is specified as a non-positive value, it is replaced by 0.001. If mnref is 

specified as a non-positive value, it is replaced by the infinite norm of the residue, evaluated 

with all displacements equal to zero.  

⎯ maxminor: The maximum number of iterations allowed. It must be greater than zero. 

It is usually ten times the number of degrees of freedom. 

⎯ maxlist: the number of BFGS corrections kept. These corrections are stored separately 

on a doubly linked circular list. Used only with the limited memory BFGS method. It is 

usually between 3 and 20. 

The next question is only asked if the user answered “Y” to the question “Were cable 

elements generated in GiD?”. 

What is the number that corresponds to the cable material in the input file material.txt? 

1 

What is the number that corresponds to the membrane material in the input file 
material.txt? 
 

1 

How many nodes will be displaced? 

0 

The following question is only asked if the answer to the previous question was a 

number bigger than zero. 

Please write the node number and the displacement in x, y and z directions – do this for 
each node. 
 

The structure.txt file that will be used to run Lights or LightsGiD will be created 

automatically in the same folder where membranelights.exe is. If the user would like to check 

anything or if there were any mistakes while entering the data asked before, the file 

structure.txt can be opened with Note Pad or Word Pad. 
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A.7. GiDLIGHTS 

GiD  

GiDLights 
Preprocess 

 

The program GiDLights makes it easier for the user that generated a mesh inside GiD 

to create one of the input files necessary to run Lights or LightsGiD (structure.txt).  

 Inside the Windows Explorer, copy the text data report file exported from GiD 

(Example.txt) into the same folder were gidlights.exe is. Click on gidlights.exe, a window will 

open where the required information should be typed: 

Please enter the name of the text data report file exported from GiD (without extension). 

Example 

Please write the following values:  
lstol, maxls, mntol, mnref, maxminor and maxlist. 

0.1      20       0.0001     0          10000                   3 

⎯ lstol: controls the accuracy of the line search. It must lie in the range 0.0  ≤ lstol < 1.0. 

Decreasing this value tends to increase the accuracy of the line search. It is usually 0.1. 

⎯ maxls: The maximum number of cubic interpolations allowed in the line search. It 

must be greater than one. It is usually 20. 

The iterations terminate if the infinity norm of the residue becomes less than or equal 

to maxnorm, which is calculated as: maxnorm = mntol * mnref. 

If mntol is specified as a non-positive value, it is replaced by 0.001. If mnref is 

specified as a non-positive value, it is replaced by the infinite norm of the residue, evaluated 

with all displacements equal to zero.  

⎯ maxminor: The maximum number of iterations allowed. It must be greater than zero. 

It is usually ten times the number of degrees of freedom. 
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⎯ maxlist: the number of BFGS corrections kept. These corrections are stored separately 

on a doubly linked circular list. Used only with the limited memory BFGS method. It is 

usually between 3 and 20. 

What is the number that corresponds to the cable material in the input file material.txt? 

1 

What is the number that corresponds to the membrane material in the input file 
material.txt? 
 

1 

How many nodes will be displaced? 

4 

The following question is only asked if the answer to the previous question was a 

number bigger than zero. 

Please write the node number and the displacement in x, y and z directions – do this for 
ach node. e  

1 -1.0 -1.0 3.0

138 1.0 -1.0 5.0

139 -1.0 1.0 5.0

185 1.0 1.0 3.0

 

The structure.txt file that will be used to run Lights or LightsGiD will be created 

automatically in the same folder where gidlights.exe is. 

 If the user would like to check anything or if there were any mistakes while entering 

the data asked before, the file structure.txt can be opened with Note Pad or Word Pad. 
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A.8. LIGHTSGiD 

 

At this point you have already created structure.txt with GiDLights or 

MembraneLights. To be able to create the other two files necessary to run Lights or 

LightsGiD (material.txt and loading.txt), please read Lights user’s manual in this CD at 

Lights/manual.pdf or Lights/manual.doc. 

 If the user started the project creating a mesh in GiD, there are two possible ways to 

get to LightsGiD, as shown in the diagram above: from MembraneLights or from GiDLights. 

 

 

A.8.1. From MembraneLights 

 

 

The form finding part was done in Membrane and now the user wants to be able to 

apply different loadings not only into membrane elements, but also cable and frame elements. 

There is an example at the CD folder Example/LightsGiD/FromMembraneLights. 

 Some changes were done manually in structure.txt created by MembraneLights 

available in this folder to add frame elements and more cable elements.  

With the autocad.scr output file from Membrane, the drawing created with the 

deformed membrane was used to draw 4 frame elements and 8 cable elements 

necessary (FrameCablesMembrane.dwg). Then only the frame elements were saved in 

Frame.dxf and only cable elements in Cables.dxf.  

 

GiDMembrane 
 

 

Membrane 
 

MembraneLights 
 

GiD  

Preprocess 
GiDLights 

 

LightsGiD 
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Inside GiD and at Files → Import → DXF the files saved in AutoCAD were 

selected (Cables.dxf or Frame.dxf), one at a time, and a mesh was generated Mesh → 

Mesh criteria → Mesh → Lines. After clicking on the lines, press ESC and go to 

Mesh → Generate Mesh and type the size of the elements (0.8). Then click on OK 

twice. After that, the text data report was exported Files → Export → Text data 

report... (Cableoriginal.txt or Frameoriginal.txt).  

Since new nodes were created, and the numbers must follow the sequence that 

is already in the structure.txt created by MembraneLights, the node numbers and 

elements were manually changed (Cablechanged.txt and Framechanged.txt) in order 

to be added inside structure.txt. 

The other input files necessary to run LightsGid, material.txt and loading.txt, are 

available at Example/LightsGiD/FromMembraneLights/Input together with structure.txt. 

These 3 files must be in the same folder were lightsgid.exe is. Click on lightsgid.exe.  

If there are membrane elements, the program will ask for the membrane highest node 

number. In this example, there are 247 nodes, but only the nodes from 1 to 185 are part of 

membrane elements. The nodes from 186 to 247 are the ones created later for extra cables and 

frame elements. 

Please write the membrane highest node number. 

185 

Wait while the program calculates the results. 

For each loading informed in loading.txt input file, the program will ask the user for a 

name in order to write the GiD postprocess files with the results after applying that loading 

(r01.post.msh, r01.post.res, r02.post.msh, r02.post.res, ...). The files results.post.res and 

results.post.msh contain the results of all loadings applied with the mesh coordinates of the 

last loading. 
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Enter a name for the file with the results of loading 1 

r01 

Wait while the program calculates. 

The output files will be created in the same folder: autocad.scr, cable.txt, 

coordinate.txt, displacement.txt, frame.txt, membrane.txt, reaction.txt, spring.txt, 

results.post.res, results.post.msh and other .post.msh and .post.res files which names are given 

by the user.  

Open AutoCAD and go to Tools → Run Script... click on autocad.scr. The 

undeformed mesh will appear (Fig. A.18) and the user can turn on other layers called “loading 

__” to see also the deformed mesh that corresponds to each loading. If some elements are 

drawn in red that means they are under compression. 

 
Figure A.18: View of membrane, cable and frame elements in AutoCAD. 

 

 

Too see the results in GiD Postprocess, open GiD and go to Files → Postprocess, then 

Files → Open and click on one of the .post.res files generated (Fig. A.19).  

 
Figure A.19: Membrane (green), cable (blue) and frame (magenta) elements view in GiD 

Postprocess. 

... 
 

 

LightsGiD GiD 
Postprocess 
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 It is possible to view different angles with View → Rotate → Trackball. 

To see the results, go to the menu View results and choose between the options 

available that show stress or displacements (Fig. A.20). 

 

 

Figure A.20: Some results in GiD Postprocess. 

 

 

A.8.2. From GiDLights 

 

 

If the user didn’t find a satisfying form with Membrane and wants to try LightsGiD by 

adding stressed cable elements or loading the membrane. There is an example at 

Example/LightsGiD/FromGiDLights.  
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 In this example membrane and cable elements will appear in the output files with high 

tensions because of the displacements imposed to the nodes. To analyze stresses caused by 

real loadings applied it is recommended to run LightsGiD again with the node coordinates of 

the best form found. Since it is still a form finding example, no frame elements were added. 

 The other input files necessary to run LightsGid, material.txt and loading.txt, are 

available at Example/LightsGiD/FromGiDLights/Input together with structure.txt. These 3 

files must be in the same folder were lightsgid.exe is. Click on lightsgid.exe.  

 If there are membrane elements, the program will ask for the membrane highest node 

number.  

Please write the membrane highest node number. 

185 

 Wait while the program calculates. 

 For each loading informed in loading.txt input file, the program will ask the user for a 

name in order to write the GiD postprocess files with the results after applying that loading 

(r01.post.msh, r01.post.res, r02.post.msh, r02.post.res, ...). The files results.post.res and 

results.post.msh contain the results of all loadings applied with the mesh coordinates of the 

last loading. 

Enter a name for the file with the results of loading 1 

r01 

 Wait while the program calculates. 

 The output files will be created in the same folder: autocad.scr, cable.txt, 

coordinate.txt, displacement.txt, frame.txt, membrane.txt, reaction.txt, spring.txt, 

results.post.res, results.post.msh and other .post.msh and .post.res files which names are given 

by the user. 
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 Open AutoCAD and go to Tools → Run Script... click on autocad.scr. The 

undeformed mesh will appear and the user can turn on other layers called “loading __” to see 

also the deformed mesh that corresponds to each loading (Fig. A.21). If some elements are 

drawn in red that means they are under compression. 

  
Figure A.21: Deformed and undeformed meshes in AutoCAD. 

 

 

Too see the results in GiD Postprocess, open GiD and go to Files → Postprocess, then 

Files → Open and click one of the .post.res files generated (Fig. A.22).  

 
Figure A.22: Membrane (green) and cable (blue) elements shown in GiD Postprocess. 

 It is possible to view different angles with View → Rotate → Trackball. 

 To see the results, go to the menu View results and choose between the options 

available that show stress or displacements (Fig. A.23). 

 

... 
 

 

LightsGiD GiD 
Postprocess 
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Figure A.23: Some results in GiD Postprocess. 

 

 

 



 79

APÊNDICE B – CD 

 

 

 Este CD contém os arquivos com o código fonte em Ada 95 e o executáveis dos 

programas Membrane, Lights, GiD, GiDLights, GiDMembrane, MembraneLights e 

LightsGiD, além do manual de utilização apresentado no Apêndice A com os arquivos 

gerados em cada etapa do exemplo mostrado.   
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